wintin Forum Index wintin
Wintin Discussion Forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Scripted Variable Doesn't Save as Expected...

 
Post new topic   Reply to topic    wintin Forum Index -> Support
View previous topic :: View next topic  
Author Message
Jezer



Joined: 29 Nov 2005
Posts: 5

PostPosted: Mon Dec 10, 2007 1:13 pm    Post subject: Scripted Variable Doesn't Save as Expected... Reply with quote

There seems to be a bug in the following script...

#defgroup {Mode}
#alias {ac-off} {#var eqmode ac;#showme ---EQ CHANGE : AC Off---;putoff;} {G|Mode} {T|WT}
#alias {ac-on} {#var eqmode ac;#showme ---EQ CHANGE : AC On---;puton;} {G|Mode} {T|WT}
#alias {putoff} {#var changerobe $$eqmode$robe;put all $invrobe;remove all;get $changerobe $mainrobe;put all $changerobe;get $invrobe $changerobe;get $mainrobe $changerobe;put $changerobe $mainrobe;} {G|Mode} {T|WT}
#alias {puton} {#var changerobe $$eqmode$robe;get $changerobe $mainrobe;get all $changerobe;put $changerobe $mainrobe;wear all;get all $invrobe;} {G|Mode} {T|WT}
#alias {regen-off} {#var eqmode regen;#showme ---EQ CHANGE : Regen Off---;putoff;} {G|Mode} {T|WT}
#alias {regen-on} {#var eqmode regen;#showme ---EQ CHANGE : Regen On---;puton;} {G|Mode} {T|WT}
#variable {acrobe} {swirling-robes} {G|Mode}
#variable {changerobe} {white-silk-robe} {G|Mode}
#variable {eqmode} {regen} {G|Mode}
#variable {healrobe} {backpack-pack-leather} {G|Mode}
#variable {invrobe} {black-persecution} {G|Mode}
#variable {mainrobe} {mystical-cloak} {G|Mode}
#variable {regenrobe} {white-silk-robe} {G|Mode}
#variable {robe} {robe} {G|Mode}
#variable {shiftrobe} {robe-dark-mysteries} {G|Mode}
#defgroup {}

When in wintin I type...

#var changerobe $$eqmode$robe;

Changerobe is set to the right value... however if the eqmode variable is changed inside an alias script and the value of changerobe is recalculated sometimes the assignment of the result to changerobe does not stick!

Proof...

inv
You are carrying:
a mystical cloak (with a single-striped white sash (Private) attached to it)
a black robe of persecution..It emits a faint humming sound!

<476hp>
#var eqmode regen
#Ok. {eqmode} now equals {regen}.
puton
You get swirling black and red robes from a mystical cloak.

<472hp>
You get an ivory torch from swirling black and red robes.
You get a swirling red and blue ring from swirling black and red robes.
You get a swirling red and blue ring from swirling black and red robes.
You get steel camail from swirling black and red robes.
You get steel camail from swirling black and red robes.

If eqmode was regen... and robe equals robe... then $$regen$robe should equal white-silk-robe... why the heck do I get swirling black and red robes out of my cloak?

Please note, also when my script loads any reference to a "$$" seems to get removed, which is really annoying.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    wintin Forum Index -> Support All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group